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About this manual

Typographical 
conventions

This manual distinguishes between different types of
information using the following conventions:

•  Terms taken from the interface itself, such as
commands, appear in bold.
•  Keys appear in small caps, for example: ”Press the
SHIFT key”.
•  Numbered lists mean there is a procedure to follow.
•  When the conjunction -or- appears next to a
paragraph, it means there is the choice of another
procedure for carrying out a given task.
•  When a menu command contains submenus, the
menu name followed by the command to select appear
in bold. Thus, ”Go to File > Open” means choose the
File menu then the Open command.

This symbol highlights important information on 

how a particular command or procedure works.

Following this symbol you will find hints and tips for
optimizing tasks, speeding up commands, and so
on.
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About your 
product

Some of the functions described in this manual may not be
available in your product.

For the complete list of specific features available in your
software, refer to the specification sheet provided with the
product.
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Introduction

Welcome !

Congratulations, you have just acquired the world’s leading
automatic identification software package!

This label design application offers you the simplest and
most effective way of creating complex documents
integrating both fixed and variable data.

Product description

The software is designed to run on any PC or IBM
compatible computer that can support the Microsoft®
Windows® graphic environment. 

Your product includes the following components:

• a CD-ROM

• complete documentation

• a license agreement and registration card

• a protection key either electronic (software key) or hard
(dongle)

Note

The Releasus.txt file contains the latest information on 
the software. This information supercedes that 
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contained in this manual.

System requirements

The basic software and hardware requirements needed to
run the application are similar to those of most applications
running on Windows™ :

• a PC or IBM compatible computer supporting 
Windows®   2000 SP4, Windows® XP SP2 or
Windows® 2003 Server 

• Windows® 2000 with 64 MB RAM (128 MB
recommended)
Windows®   XP or Windows® 2003 Server  with 128
MB RAM (256 MB recommended)

• A VGA monitor or better

• A hard drive with at least 50MB free disk space  

• A CD-ROM drive

Installation

Before running the installation program, check the
configuration of your PC.

1 Place the CD-ROM in the correct drive.

To eliminate the possibility of compatibility issues, 
please remove all previous versions of this labe-

ling software that may be installed on your system.

Before installing this software please save your
work and close all other programs.
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The Installation window appears.

If the CD-ROM does not start up automatically:

2  Go to Start > Run... , then type the letter of the CD-ROM
drive followed by the filename cdsetup.exe (e.g.
D:\cdsetup.exe).

3  Select the product you wish to install, then click on the
Install button and follow the instructions displayed on your
screen.

Software protection 

Your software can be protected using a software key ( an
electronic code) or a hardware key ( a dongle).  

The dongle is a small electronic device that you plug into
your PC’s parallel or USB port before launching the
software.  Without the hardware protection key, the program
will run in ’evaluation’ mode. You will not be able to save
your labels, ’e’ will be replaced with ’x’, ’0’ with ’5’ and
images will be crossed when printing.

The software key is an electronic code that is requested by
the Activation Wizard when you launch the software for the
first time or for as long as you are running a trial version.  If
you are using a trial software key, you will be given 100 runs
or 30 days to try the product with all of the product’s
functionalities available to you.

Once the product has been installed, remember to
fill-in and mail the registration card. Registering
your product gives you access to technical support
from your supplier and pre-release information on
new products.

When you launch the application, if the protection
key does not correspond to your product version, a
dialog box will appear providing the necessary
instructions.
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You must first run your labeling software installation and
then activate or connect the protection key to your
computer.

Hardware Key 
connection

If you have purchased the software with a dongle, you may
choose between a USB or parallel port dongle.

Connecting the parallel key

Figure 1 Connecting the dongle to the parallel port of your PC

Connecting the USB key

Figure 2 Connecting the dongle to the USB port of your PC

When you use a USB key and have multiple USB ports, it
does not matter which port you use. If you do not have an
available USB port, you can use a USB expander hub. USB

If you need to use a printer on the same parallel
port, simply plug it into the software protection key.
In this case, it may be necessary to switch the
printer on in order for the software protection key
to be recognized.

 

USB Port 

Key 
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devices are hot-swappable, meaning you can plug and
unplug them into the bus any time, without restarting the PC

Note

Drivers can be installed while the application is running. 
However you must restart your labeling software for the 
changes to take effect.

Error messages 
when launching 
the software

If you are prompted with an error message when launching
the software, please check the following items:

• The administrative rights. You must have local
administrative rights on your PC so that the key
installation works properly. If you do not have them, you
will be prompted an error message when launching the
software. You will have to manually install the drivers.

• Drivers installation. If you had trouble during installation
or if you are prompted an error message when launching
the software, you will have to manually install the drivers.

• The key. If you are prompted an error message when
launching the software, check that the connected key
works with your labeling software.

Driver update. If you are prompted an error message when
launching the software, your driver may not be updated. To
update your driver you have to download it from 
ftp://ftp.ealaddin.com/pub/hasp/NEW_RELEASES/driver/
hdd32.zip.

Activating the 
software key 
protection 

Once you have installed the labeling software, the
Activation Wizard will be launched taking you through the
software key protection process. 

To Activate the software key

1 In the Activation wizard, select Activate then click on Next

USB hardware keys are not supported using Win-
dows 95 and Windows NT4 operating systems.
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There are three possible activation methods; Internet
(Automatic), Fax / email, and phone

Internet activation method

1 Select Automatic from the list of activation modes.  This
option allows the activation of the software key via a
secure Internet connection.  This is the quickest and
easiest option available

2  Input your information in the User Registration form.
Remember that all fields marked by an asterisk (*) are
required. Click on Next

3  Enter the activation code provided with the product and
click on Next

4  Click on Finish if your activation results are successful. If
any problems were encountered, a message will inform you
that the activation has failed and an error will be displayed.

Fax / Email activation method

1 Select the Fax / Email activation method

2  Input your information in the User Registration form.
Remember that all fields marked by an asterisk (*) are
required. Click on Next

3  Enter the activation code provided with the product and
click on Next

4  Click the Create Form... button.  An Activation Request
Form will be created with all the required user information.
This form must be sent  by fax  or email in order to receive
the response code. Please see the contact info on your
screen for more information. 

5  Click Next. While waiting for a Response Code, you may
choose to launch your software and begin using it, or, close
it and return to the activation process once you have
received your response code.

Once you have received your Response Code, you can
return to the activation process by restarting the wizard and
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click Next until you reach the screen from step 5 and choose
the option Enter the Response Code. All the options you
had previously selected in the wizard will be retained.

6  Enter the Response Code provided to you and click on
Next

7  Click on Finish if your activation results are successful. If
any problems were encountered, a message will inform you
that the activation has failed and an error will be displayed.

Telephone activation method

1 Select the Telephone activation method

2  Enter the activation code provided with the product and
click on Next

3  Call your contact (For Europe or Asia, please contact your
Reseller.  For the Americas, please contact Teklynx at +1-
414-535-6200)

Note

You will be required to fill out a User Registration via the 
phone.  Please have your company information at hand.

4  Enter the Response Code provided to you by your
reseller and click on Next

5  Click on Finish if your activation results are successful. If
any problems were encountered, a message will inform you
that the activation has failed and an error will be displayed.

Installing the 
driver key 
manually 

If you want to install your key driver manually, do the
following:

•  Click on Start, then Run. 
•  Enter your installation file path then type the following

command: \hinstall.exe -i 

Note

It is recommended to close your labeling software and 
other applications before installing your driver.
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Launching the program

1 Go to Start > Programs.

2  Select the name you gave to the program group during
installation (by default, it is the name of the application).

The main window appears on the screen.
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Discovering the Interface

Description of the main window

This section presents a general overview of the main interface
elements as they appear in the main window at the beginning of
a work session.

Menu bar The menu bar comprises seven drop-down menus: File, Edit,
View, Object, Data Source, Tools, Window and Help.

To open a menu:

1 Click on it with the left mouse button.

2  Then choose the required command.

Workspace The workspace is the entire middle portion of the window,
located between the graduated rulers and the scroll bars. It
includes the frame that outlines the physical limits of the
document, where the objects to be printed are placed, as well
as a non-printable area where you can insert comments or
objects that you do not wish to appear in the printed label.

To access commands using the keyboard, use the
keyboard shortcuts. Press ALT then the key
corresponding to the letter underlined in the menu
name followed by the key corresponding to the
letter underlined in the command name.
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Document When you start a new session, the program displays a frame
aligned with the top left-hand corner of the window. This
frame represents the physical limits of the document to be
printed.  The objects that make up your document should be
placed inside it.

Status bar Located on the lower edge of the window, the status bar
displays the name of the selected printer, the
communication port to which it is connected, and the cx and
cy dimensions of the object selected.

Figure 3 The status bar

Standard 
toolbar

These tools allow you to execute common tasks more
quickly than by using the menus.

To select a tool:

•  Click on the corresponding button.

Figure 4 The Standard toolbar

View toolbar The View toolbar offers you a number of display options.

Figure 5 The View toolbar
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To change the view mode:

•  Click on the required view mode:

Creation 
Toolbar

The creation toolbar contains a number of buttons, each of
which represents a tool. With these tools you can create and
manipulate objects.

Figure 6 The Creation toolbar

Button Name of tool Use

Name displaying variable names.

Size displaying variable size
maximum.

Contents displaying variable values.

Form displaying the Form.

Document
Browser

displaying the Document
Browser.

Zoom allows you to increase or
decrease object detail.

All these options can also be accessed via the
View menu.
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Button Name of tool Use

Select objects select and manipulating
all types of objects.

Text generation creat fixed and variable
text.

Barcode generation creat fixed and variable
barcodes.

Image import insert images.

External object
insertion

insert objects external to
the application.

Line drawing draw horizontal or vertical
lines.

Rectangle drawing draw rectangles or
squares.

Circle or ellipse
drawing

draw circular shapes.

Polygon drawing draw free shapes
composed of lines.

Oblique line drawing draw diagonals.

Rounded rectangle
drawing

draw rectangles with
rounded corners.

Shapes Gallery tool import ready-to-use
shapes into the document

UCC/EAN 128 and
Maxicode wizards

create barcodes with the
UCC/EAN 128 and
Maxicode wizards

Plug-ins create TextArt, ListFields
and RichText Fields
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Document 
Browser

The Document Browser contains two tabs: Data Sources
and Objects. The arrow up and arrow down keys on your
keyboard allow you to move up and down the tree. The +
and - symbols allow you to expand or shrink the list and
display the list of variables associated with each data source
or the objects available for each category.

The Data Sources tab displays the data sources and the
number of variables associated. You can insert variable
objects simply by dragging and dropping them into your
document. You can also add, delete and modify variable
properties using the context menu.

The Objects tab displays the number of objects created
according to type, and their properties such as position,
height and width. You can also use this tab to select an
object and change its position.

Figure 7 The Document Browser 

About data sources

A data source contains a list of variables fed by data from
the same source.
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When you select a data source, you are indicating where the
required data is located, and what type of data it is. The data
can be of internal origin (Date, Counter) or external to the
application (Database, direct data entry using the Form).

The different data sources available in the Document
Browser’s Data Sources tab are the following: Database,
Date, Form, Formula and Counter.

Graduated 
rulers

The rulers allow you to pinpoint the position of the mouse
pointer and place the various objects you include in your
document with total precision. They may be configured in
inches or millimeters using the Tools > Options > Display
command.

•  Double-clicking on the left half of the horizontal ruler
reduces the display scale.

•  Double-clicking on the right half of the horizontal ruler
increases the display scale.

Rotation button Clicking on  located in the top-left corner of your
documents allows you to rotate the document on the screen
90°, 180°, 270° or 360°. Screen rotation is merely a display
feature, and has no effect on printing.

To rotate the document:

•  Click on the rotation button with the left mouse button to
rotate the document 90° to the left.

•  Click on the rotation button with the right mouse button to
rotate the button 90° to the right.

You can display the Zoom factor context menu by
right-clicking on the horizontal ruler, or the
Orientation context menu by right-clicking on the
vertical ruler.
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Color palette The color palette is displayed at the bottom of the
workspace and allows you to modify the color of any object
in your document (text, barcodes, shapes and monochrome
images).

Figure 8 The color palette

To change the color of an object:

1 Select the required object.

2  Click on a color in the palette with the left mouse button
to apply text, line or outline color.

3  Click on a color in the palette with the right mouse button
to apply background color.

Note

This button  removes the background color from an 
object.

You can obtain the same document rotation effect
by using the View > Orientation command, or by
clicking on the vertical ruler with the right mouse
button to display the context menu.

The Online Help provides full information on
choosing the color palette, customizing it, and so
on.
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Creating Your First Label

Introduction

The purpose of this chapter is to get you off to a quick start
with the software by familiarizing you with its most common
functions. We will demonstrate just how quickly and easily a
label can be constructed by creating a label step-by-step in
this chapter. 

We are going to create the following label:

Figure 9 Introduction to the example label
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Setting up the interface

With a simple click of the mouse, the interface can be
instantly translated into the language of your choice.

1 Go to Tools > Options...

2  Select the required language and unit of measurement as
shown in the Figure below, then click on OK.

Figure 10 The Options dialog box

You can access the Online Help at any time by
pressing the F1 key.
You can also access it from the dialog boxes by
clicking on the Help button.

You are recommended to save your document at
regular intervals so as to avoid losing data in the
event of a problem such as a power failure.
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Selecting the printer

Before starting, you will need to define the printer you wish
to use as not all printers share the same characteristics. As
a result, settings such as choice of character fonts, page
formats, and so on, may differ according to the model
chosen.  

•  Go to File > Select printer...
-or-
Click on  (or the F5 key).

The Printer dialog appears on the screen.

Figure 11 The Printer dialog box

If the printer you wish to use is not listed in the box, you will
need to add it.

To add a printer:

1 Click on the Add button, then select the printer from the
Model list.

2  Select the port on which you wish to install the printer.

3  Click on OK.

You are now back at the Printer dialog box.  

Windows Drivers

Drivers provided
with the 
application

Note : 
Drivers provided with the application are indicated by an icon
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4  Select the printer you have just added, then click on OK.

Note

To create the example label described in this manual, 
we recommend you use a printer that uses the drivers 
provided with the application

Document page setup

Once you have selected the printer on which the label will be
printed, you can begin creating your document. The first
stage involves setting its dimensions.

1 Go to File > Page setup...
-or-
click on 

The Page setup dialog box appears on the screen.

You are recommended to use printer fonts and
barcodes as this reduces data transfer time and
thus optimizes label printing speed.

The Stock tab allows you to open an
existing stock, or create a new one

The Label tab allows you to define
the size of the document and the
number of documents per row and
per column on the page

The Page tab allows you to define
the page format

The Margins  tab allows you to
define the margins and the distance
between documents on the same
page
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Figure 12 The Page setup dialog box

2  Click on the Label tab and enter the following information:
- Width: 77
- Height: 82
- Corner roundness: 1
- Number of labels per row: 1
- Number of labels per column: 1

3  Click on the Page tab and enter the following information:
- Page size: Customized
- Automatic sizing: yes

4  Click on the Margins tab and enter the following
information:
- Left margin: 1
- Top margin: 1.5
- Gap between columns: 1

5  Click on OK.

The workspace displays the outline of your label.

Creating Database Variables

The Database data source allows you to import data from a
database.

1 Go to Data source > Databases > Create/Edit query...

2  Select ODBC

3  Click on the database icon button

Page setup parameters may differ according to the
printer used. In this case, messages will guide you
through the process of modifying the values
suggested in this example.
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4  Click on Add...

5  Select the Microsoft Access Database driver (*.mdb)

6  Click on Finish

7  Name the database: “Fruits” and click OK

8  Select the new database from the list and click OK

9  In the Select Data Source drop-down menu, select
Fruits and find its location
C:\ProgramFiles\Codesoft8\Libraries\Data\Fruits.mdb

10  Select Products from the list of tables

11  Click  Select All

12  Click OK

The variables are created automatically and are displayed
under Database in the document browser. They will carry
the same field name as those defined in your database.

To add a variable to the document, select a Database
variable from the list, then drag and drop it into the
document (see Creating text variables).

Creating the label

Creating text 1 Select the Text generation tool, then click inside the
workspace.

2  Enter ”From:”.

3  Using the Select tool, right-click on the text you have just
created. and go to Properties...

4  Complete the dialog box as shown
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.

Figure 13 The Text dialog box

5  Repeat steps 1 and 2 for the following text:

• ”Best before:” 
• ”Shipping Date” 
• “Package Price:”
• “Quantity:”
• “Weight:”

6  Create also a empty text box in which the ProductName
variables will be inserted. (see Creating text variables)

To retain the set text attributes for all  new
textboxes, right-click on the configured textbox
and select Set as default.
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To apply color to the text.

1 Select ”Best before”, then click on the required color in the
palette with the left mouse button.

The text will immediately display the color chosen.

2  Select ”Shipping Date:”, then click on the required color in
the palette with the right mouse button.

The text will immediately display a background color.

Creating text 
variables 

Once your textboxes have been created, place the data
from your database on your label by dragging and dropping
the various database items onto your label.  Remember to
place all the ProductNames in an empty textbox. The
variables to be moved over are:  OrderQty, Origin,
Proce_per_kg, ProdNameCh, ProdNameFr, ProdNameGe,
ProdNameIt, ProdNameRu, ProdNameSp, ProdNameUs.
When you drop the variable into the label, you will be given
a choice to create it as a text,  barcode or image... For the
above mentioned items, always choose Text.

Creating date 
variables 

1 Right-click on the date item in the document browser and
select Add...

2  Select a date format

3  Drag and drop the newly created date variable into the
label as a text item

Configuring a date variable

1 Repeat steps 1 and 2

2  Click the Options tab in the Date variable dialog box

3  Add a fixed value of 15 (days) and click ok.

This will add 15 calendar days to the current date - used for
the ”Best Before” date variable.

Creating 
barcodes

1 Select the CodeArticle variable from the list of database
items in your document browser
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2  Drag and drop it into the label as a barcode

You can change the type of barcode it produces by right-
clicking on the barcode, selecting Properties... from the
context menu and defining the settings.

Figure 14 The Barcode dialog box

To access the Barcode dialog box more quickly,
double-click on the object.
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Creating 
Shapes

To draw a line:

1 Select the Square drawing tool to draw the squares in the
bottom half of the label

2  Click on the point at which you wish to begin drawing the
square and, holding the left button down, drag the mouse.

3  Once you have drawn the squares, select them and go to
Properties...  in the context menu.

The Shape dialog box appears.

4  Enter ”0.20” in the Line width box, then click on OK.

Importing an 
image

Your software allows you to insert images and company
logos into your label to give it that finishing touch.

A number of formats can be imported, including bmp, dib,
gif, and so on.

To import an image:

1 Click on the Image import tool.

2  Click inside the workspace.

The Open dialog box appears.

3  Select Samples\Images\banana.jpg, then click on OK.

4  Readjust the size of the image as necessary. Click on a
handle, and, holding the left button down, drag the mouse
until the required dimension is achieved.

To help you find the image to be imported, display
the file preview by clicking on .
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Counter The Counter data source contains a list of variables created
when you need them. These variables are fed by data
calculated either by the computer, or by the printer. 

The content of the variable changes as printing advances,
according to an initial value and an increment value.

To create a Counter variable:

1 Select Counter in the Document Browser’s Data
Source tab.

2  Choose Add... in the context menu.

The variable created appears automatically under the
selected data source.

To define the properties of a Counter variable:

1 Select the Counter variable, then choose Variable
properties... in the context menu.

2  Select the type of counter.

3  Enter a value in the Increment box. The default increment
is +1.

4  Enter a value in the Start value box. The default start
value is 0.

5  Click on OK.

To insert the Counter into the document:

1 Select the Text generation tool.

2  Select the Counter variable, then drag and drop it into the
document.

The Counter appears.
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Saving the document

Before printing your label, save your document.

1 Go to File > Save.

The Save as dialog box appears if you are saving your
document for the first time.

2  Name your document, then click on OK.

Printing your document

You have finished creating your label, so you can now print
it.

1 Go to File > Print...
or
click on the  button.

2  The Print dialog box appears.

Don’t forget to activate Contents mode if you wish
to display the current value of the counter.
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Figure 15 The Print dialog box

Click on More >> or << Less to display/hide the Expanded
Print section 

3  To start printing, click on OK

The Quantity box allows
you to define the total
number of labels to print

The Start at box allows
you to start printing at a
given label

Complete the different
boxes as required

Press the CTRL+P key to access the Print dialog
box more quickly.
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