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Label Design Tutorial

Introduction

This tutorial walks you through the process of creating two
different sample label designs. The steps covered in this
chapter introduce some of the most frequently used features
and functions of the label design software. 

• Designing a Product Label (Beginner) provides step-by-
step instructions for selecting a printer, completing your 
label setup, and adding several different types of fields 
including text, bar code, and picture fields. We will also 
add a line, a date stamp, and a pick list field that allows 
you to select from a list at print time.

• Designing an Inventory Label (Advanced) covers more 
advanced features available only in the mid-range and 
high-end editions of the label design software. In this 
tutorial you will add text, bar code, and picture fields that 
get their values from a database. We will also add a hid-
den field, an incrementing serial file field, and a linked 
field that combines text with an existing field on the label.

Designing a Product Label (Beginner)

In this section we will create a basic product label. The label is
intended for use on a package of coffee, and includes product
specific information such as product name, flavor, picture, and
sell by date, as well as a UPC bar code. 

The following is a sample of the product label we will create.

e
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Figure 1 Product Label

Note This type of label would typically be printed using a thermal or 
thermal transfer label printer; even if you do not have this type 
of printer or label stock size available, you can still go through 
the basic label design steps covered in this tutorial.

Selecting a 
Printer

The first step to designing a label is to select the printer you
will use for printing. The printer model selected determines
what options are available as well as the label’s size
limitations.

X To select a printer for your label design:

1 Start the label design software.

2 On the File menu, click Select Printer.

The Select Printer dialog box appears.
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Figure 2 Select Printer

3 Do one of the following:

• If you previously installed a thermal/thermal transfer 
printer driver for use with this label design program, 
click the Printer drop-down arrow and select your 
printer from the list of installed printers.

• If you have not yet installed a thermal/thermal trans-
fer printer driver for use with this label design pro-
gram, click Install, select your printer’s manufacturer 
and model, and again click Install. The new printer 
will be copied to the Installed Printers list. Click 
Close.

4 Click OK.

Label Setup When you start the program, a default label appears ready for
you to design. The label width, height, margins, and other
general setup options can be changed using the tabs on the
Label Setup dialog box.

X To set the units of measure for the label:

1 On the Options menu, click Configuration, and then 
click the Display tab.

2 In the Units box, click inches.

3 Click OK.

X To set up the label:

1 On the Edit menu, click Label Setup.

The Label Setup dialog box appears.
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Figure 3 Label Setup

Note The settings appearing on the Label Setup tab will vary 
depending on the type of printer selected for this label design.

2 On the Label Setup tab, set the following label proper-
ties:

Width: 4.0

Height: 2.5

Left Margin: 0

Labels Across: 1

3 Leave the other label setup settings at their defaults.

4 Click OK.

Adding Text 1 Do one of the following:

• On the Draw menu, click Text.

• Click Add Text  on the Drawtools Bar.

The Text properties dialog box appears.
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Figure 4 Text Properties

Note The settings available on the Text tab will vary depending on 
whether you are using a printer-resident font or a TrueType 
font.

2 In the Font box, click TrueType Fonts.

3 On the Text tab, set the following properties for this text 
field:

TrueType Font: Times New Roman

Point Size: 18

Language: Western

Style: Bold & Italic

Width %: 100

Rotation: Normal

Data Source: Fixed

Text String: Central Perk Gourmet Coffee

4 Click the Options tab and in the Field Name box, type 
Brand.

5 Click the Color tab, click the color box drop-down arrow 
and select a color for the text. (Note: If you do not have a 
color printer, colors have no effect on the output.)

6 Click OK.
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7 Use the mouse to position the text field near the top edge 
of the label and click once to place the text (you do not 
need to worry about precise field positioning at this time).

8 On the File menu, click Save As. Browse to save the label 
to your desktop or a temporary folder and enter a file 
name (like beginner.lbl), and then click Save.

Adding a Line 1 Do one of the following:

• On the Draw menu, click Line.

• Click Add Line  on the Drawtools Bar.

Your cursor appears as a crosshair in the design window.

2 Click below the Central Perk Gourmet Coffees text and 
draw a horizontal line.

3 Right-click the line, and click Edit.

The Line dialog box appears.

4 In the Width box, enter 3.80.

5 In the Height (thickness) box, enter .05.

6 Click OK.

Positioning 
Objects on the 
Label

We will now use the Float Bar tool buttons to precisely
position the text and line fields on the label.

1 Click the View menu and ensure that a checkmark 
appears next to the Float Bar toolbar option.

2 On the label design, hold down the SHIFT key while click-
ing on the Central Perk Gourmet Coffees text and on 
the horizontal line, and then click the Center Horizon-

tally  button on the Float Bar.

3 On the File menu, click Save to save your changes.

Adding a Picture 1 Do one of the following:

• On the Draw menu, click Picture.

• Click Add Picture  on the Drawtools Bar.

The Picture properties dialog box appears.
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Figure 5 Picture Properties

2 On the Pictures tab, set the following properties for this 
picture field:

Rotation: Normal

Ratio: Fixed Ratio

Data Source: Fixed

Pictures: coffee.jpg

3 Select the preview check box to display the selected pic-
ture.

4 Click OK and then click in the lower left corner of the label 
to place the picture.

5 If the picture appears to be too small for the label, you 
can easily size the picture while keeping the aspect ratio 
of the height and width the same. To do this, click on one 
of the four corners of the object handles (so the cursor is 
at a diagonal) and drag to increase the size. 

At this point, your label should look something like this:
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Figure 6 Unfinished Label

6 On the File menu, click Save to save your changes.

Adding a Pick List 
Field

A pick list file contains values from which you can select at
print time. We will create a pick list file that contains three
different coffee flavors. At print time, you can then simply click
the drop-list and select the appropriate flavor to print on the
label.

X To create a pick list file:

1 On the Options menu, click Pick List Setup.

The Pick List Setup dialog box appears.

2 Click New.

The Pick List File: new file dialog box appears.
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Figure 7 New Pick List File

3 Click New, type Dark Roast, and click OK.

The value is added to the pick list.

4 Add the Espresso and Colombian values to the pick list.

5 Click Dark Roast, and then click As Default.

6 Click Sort.

7 Click the Force data to come from list check box, and 
click OK.

The File Name dialog box appears.

8 Type flavors.pkl, click OK, and then click Exit to return 
to the design window.

9 On the File menu, click Save to save your changes.

X To add a field with a Pick List data source:

1 On the Draw menu, click Text.

The Text properties dialog box appears.

2 Select these font properties:

Font: TrueType Fonts

TrueType Font: Arial

Point Size: 14
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Style: Normal

Rotation: Normal

3 In the Data Source box, click Pick List.

4 In the Pick List box, click flavors.pkl.

5 In the Prompt box, type Flavor.

Figure 8 Pick List Data Source

6 Click the Options tab.

7 In the Required box, click Yes to prevent users from 
printing without entering a value for this field.

8 In the Clear After Print box, click Yes to restore the field 
to its default after printing.

9 Click OK, and place the field on the right side of the label, 
below the horizontal line.

Because its data source is a pick list file accessed at print 
time, placeholder text (letters A-J) will display on the label 
for this field.

10 On the File menu, click Save to save your changes.
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Adding a Bar Code 1 Do one of the following:

• On the Draw menu, click Bar Code.

• Click Add Bar Code  on the Drawtools Bar.

The Bar Code properties dialog box appears.

Figure 9 Bar Code Properties

Note The default values and properties appearing on the Bar Code 
tab will differ depending on the type of bar code that you 
select.

2 On the Bar Code tab, set the following properties for this 
field:

Bar Code Type: UPC-A

Data Source: Fixed

Bar Code Value: 45634563456

3 Leave the other bar code settings at their defaults.

4 Click the Human Readable tab.

5 In the Human Readable box, click Yes.

6 Click the Options tab.

7 In the Field Name box, type UPC.

8 Click OK and then click on the right side of the label to 
place the bar code below the pick list field. 

9 On the File menu, click Save to save your changes.
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Adding a Date 
Stamp

1 On the Draw menu, click Text.

The Text properties dialog box appears.

2 Select these font properties:

Font: TrueType Fonts

TrueType Font: Arial

Point Size: 9

Style: Normal

Rotation: Normal

3 In the Data Source box, click Date stamp.

4 In the Date Format box, click mmm dd, yyyy.

5 In the Date Offset box, type 6.

6 In the Offset Unit box, click Months.

7 Click the Options tab and in the Field Name box, type 
SellDate (no spaces).

8 Click the Color tab, click the color box drop-down arrow 
and select a color for the text.

9 Click OK, and place the field in the lower right corner of 
the label.

The date appears, offset by 6 months.

10 Now to add “Sell By:” in front of the date, on the Draw 
menu, click Text.

The Text properties dialog box appears.

11 Select these font properties:

Font: TrueType Fonts

TrueType Font: Arial

Point Size: 9

Style: Normal

Rotation: Normal

Data Source: Fixed

Text String: Sell By:

12 Click the Color tab, and select the same color you chose 
previously for the date stamp.
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13 Click OK, and place the field to the left of the date stamp 
field.

14 Hold down the SHIFT key while clicking on the Sell By: 
text and on the date stamp field, and then click the Align 

Top  button on the Float Bar.

15 On the File menu, click Save to save your changes.

Printing the Label 1 On the File menu, click Print.

The Quick Printing dialog box appears.

Figure 10 Quick Printing Dialog Box

2 In the Flavor box, click Espresso, and then click Print.

The label is printed.

3 Click Close to return to the design window.
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Designing an Inventory Label (Advanced)

In this section we will create a slightly more advanced parts
inventory label. The label is intended to be used as a shelf
label, and includes information such as the part description,
part number, and picture, as well as a bar coded stocking
number. 

The following is a sample of the parts inventory label we will
create.

Figure 11 Inventory Label

Note This type of label would typically be printed using a thermal or 
thermal transfer label printer; even if you do not have this type 
of printer or label stock size available, you can still go through 
the basic label design steps covered in this tutorial.

Many of the features used in this tutorial are 
available only in the mid-range and high-end edi-
tions of the label design software.
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X To set up the label:

1 Close any open label design files.

2 Right-click on the blank label design area and select Label 
Setup.

The Label Setup dialog box appears.

3 On the Label Setup tab, set the following label proper-
ties:

Width: 3.0

Height: 1.5

Left Margin: 0.0

Labels Across: 1

Horizontal Gap: 0.0

4 Leave the other label setup settings at their defaults.

5 Click OK.

6 On the Style Bar toolbar (above the design area), click 
the Zoom factor drop-down list and click Full to design 
the label using a magnified display.

To see the actual size of the label we’ll be designing, click 
100%.

Adding a dBase 
Text Field 

Before retrieving data from a dBase database, you must
provide the label design software with the location of your
database files. For purposes of this example, we will be using
the fittings.dbf sample database file that is installed with the
program. 

X To add a field that uses a .dbf database:

1 On the Draw menu, click Text.

The Text properties dialog box appears.

Note You can use the dBase data source for text, paragraphs, bar 
codes, 2D bar codes, and pictures.
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2 Select these font properties:

Font: TrueType Fonts

TrueType Font: Arial Black

Point Size: 10

Style: Normal

Rotation: Normal

3 In the Data Source box, click dBase.

Figure 12 dBase Data Source

4 In the Database box, click fittings.dbf.

Fittings.dbf is a sample dBase file that installs with the 
program.

5 In the Key field box, click PART.

The key field is the database field that allows you to locate 
the desired record.

6 In the Print field box, click DESC1.

The print field is the database field that contains the data 
you want to print on the label. It can be the same as the 
key field, or another field in the database.

7 In the Keyfield Data box, click Prompted.
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The keyfield data defines the source of the key field 
(either prompted at print time or linked to another field on 
the label).

8 In the Prompt box, type Part Number.

9 Click the Options tab, and set the following properties for 
this field:

Increment: 1

Copies: 1

Reset after each record: No

Clear After Print: No

Field Name: PartDesc

10 Leave the other Options tab settings at their defaults.

11 Click OK, and place the field in the top left corner of the 
label.

12 On the Style bar, click the  button to display the name 

of the field (Name Mode), click the  button to display 

the field length (XXX Mode), and finally, click the  but-

ton to display the value of the first record in the database 
(Value Mode). Leave the field display in Value Mode.

13 On the File menu, click Save As. Browse to save the label 
to your desktop or a temporary folder and enter a file 
name (like advanced.lbl), and then click Save.
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Adding a Hidden 
Field

The second dBase field we will add to the label will be set up
as a hidden field. This means that it will be available to use to
create other linked fields, but it will not print on the label. Later
in this section we will add a field that links to this hidden field.

X To add a hidden text field:

1 On the Draw menu, click Text.

The Text properties dialog box appears.

2 In the Data Source box, click dBase.

3 In the Database box, click fittings.dbf.

4 In the Print field box, click PART.

5 Click the Options tab, and set the following properties for 
this field:

Increment: 1

Copies: 1

Reset after each record: No

Field Name: PartNo

Hidden: Yes

6 Leave the other Options tab settings at their defaults.

7 Click OK, and place the field in the top right corner of the 
label.

The field appears in red to indicate that it is a hidden field. 
It displays on the label for placement purposes, but will 
not print on the label.

8 On the File menu, click Save to save your changes.
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Adding Lines In the following steps we will add a horizontal line and a
vertical line, as shown in the following figure.

Figure 13 Horizontal and Vertical Lines

1 On the Draw menu, click Line.

Your cursor appears as a crosshair in the design window.

2 Click on the left side of the label below the two dBase text 
fields, and draw a horizontal line across the entire label as 
shown in the figure above.

3 Right-click the line, and click Edit.

The Line dialog box appears.

4 In the Width box, enter 2.86.

5 In the Height (thickness) box, enter .02.

6 Click OK.

7 On the Draw menu, click Line again and this time add a 
vertical line in the middle of the label, as shown in the fig-
ure.

8 Right-click the line, and click Edit.

The Line dialog box appears.
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9 In the Width box, enter .02.

10 In the Height (thickness) box, enter 1.0.

11 Click OK.

12 On the File menu, click Save to save your changes.

Adding a Serial 
Number

To set up an incrementing serial number you must specify
Serial file as the data source and link the field to a serial file.
The serial file allows the program to track the last serial
number printed and start the next print job with the next
number in the series.

In order to set up a serial number field, you first need to create
a serial file. The serial file contains the starting value for the
counter; that is, the first number to be printed.

X To create a serial file:

1 On the Options menu, click Serial Files.

The Serial files dialog box appears.

2 Click New.

3 The Serial file: Untitled dialog box appears prompting 
you to enter the starting value for the counter; that is, the 
first serial number to be printed.

Figure 14 Serial Number Starting Value

4 In the Serial Number box, type 100001, and click OK.

5 The Save Serial Files dialog box appears prompting you 
to name the serial file.

6 In the Serial file box, type stockno.srl, click OK, and 
then click Exit to return to the design window.
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X To add a serial number (link to the serial file):

1 On the Draw menu, click Bar Code.

The Bar Code properties dialog box appears.

2 Select these bar code properties:

Bar Code Type: Interleaved 2 of 5

Rotation: Normal

Multiplier: 2 (10 mils)

Bar-width Ratio: 2:1

Height: 0.50

3 In the Data Source box, click Serial file.

4 In the Serial file box, click stockno.srl.

5 Click the Human Readable tab and click No for the 
Human Readable setting.

6 Click the Options tab and set the following properties:

Increment: 1

Copies: 1

Reset after each record: No

Field Name: StockNo

7 Leave the other Options tab settings at their defaults.

8 Click OK, and place the field in the lower right part of the 
label.

9 On the File menu, click Save to save your changes.

Adding Linked 
Fields

You can use the Linked data source to combine text and fields
(or to combine two fields) into one field on the label.

X To combine text with a dBase field:

1 On the Draw menu, click Text.

The Text properties dialog box appears.

Note You can use the Linked data source for text, bar codes, 2D bar 
codes, pictures and TextArt objects.
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2 Select these font properties:

Font: TrueType Fonts

TrueType Font: Arial

Point Size: 8

Style: Normal

Rotation: Normal

3 In the Data Source box, click Linked.

4 In the Linked Fields box, type the following:

“PART: “ + PartNo

Figure 15 Linked Field

5 Click the Options tab, and in the Field Name box, type 
LinkedPartNo.

6 Leave the other Options tab settings at their defaults.

7 Click OK, and place the field on the left side of the label, 
slightly below the horizontal line.

Note Because its data is being accessed from a dBase file at print 
time, the PartNo portion of the linked expression will not 
display while in Value Mode.
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X To combine text with a Serial File field:

1 On the Draw menu, click Text.

The Text properties dialog box appears.

2 Select these font properties:

Font: TrueType Fonts

TrueType Font: Arial

Point Size: 8

Style: Normal

Rotation: Normal

3 In the Data Source box, click Linked.

4 In the Linked Fields box, type the following:

“STOCK #: “ + StockNo

5 Click the Options tab, and in the Field Name box, type 
LinkedStockNo.

6 Leave the other Options tab settings at their defaults.

7 Click OK, and place the field on the right side of the label, 
above the bar code field.

8 On the File menu, click Save to save your changes.

Adding a dBase 
Picture Field

In order to automatically include the correct picture on each
label, we will access the name of the picture file from a
database at print time using the dBase data source. The
picture to be printed on each label is determined by a graphic
file name in the database.

1 On the Draw menu, click Picture.

2 Set the following properties for the picture field:

Rotation: Normal

Ratio: Fixed Ratio

Data Source: dBase

Database: fittings.dbf

Print field: PICTURE

3 Click OK, and place the picture field on the left side of the 
label, below the LinkedPartNo field.
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Note Because its value will be accessed from a dBase file at print 
time, the picture field appears on the label as a double-
bordered frame. The correct picture will print on the label, 
however, based on the corresponding graphic file name in the 
database.

4 On the File menu, click Save to save your changes.

Your label design should now look similar to the label 
below.

Figure 16 Label with Picture Field

Positioning 
Objects on the 
Label

We will now use the Float Bar tool buttons to position objects
on the label in relation to each other.

1 Click the View menu and ensure that a checkmark 
appears next to the Float Bar toolbar option.

2 On the label design, click the horizontal line to select it, 

and then click the Center Horizontally  button on the 

Float Bar.

3 Click the vertical line and then click the Center Horizon-

tally  button.
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4 Hold down the SHIFT key while clicking on the PartDesc 
and LinkedPartNo fields, and then click the Align Left 

 button.

5 Hold down the SHIFT key while clicking on the Linked 
PartNo and LinkedStockNo fields, and then click the 

Align Top  button.

6 On the File menu, click Save to save your changes.

Printing the Label Labels that contain fields populated by a database can require
user input at print time if the Key Field Data property is set
to Prompted. 

If set to Prompted, then a  button appears at print time
for displaying the database records in a grid. The database grid
allows you to select, scroll to, and search for the records you
want to print.

X To print a label that uses a database field:

1 On the File menu, click Print.

The Quick Printing dialog box appears.

Figure 17 Quick Printing Dialog Box

2 Click  located to the right of the PART box.

The fittings.dbf database file appears in the database 
grid.
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Figure 18 Database Grid

3 Hold down the CTRL key while you click on the Cap Nut 
Connector, Hex Nut, Bronze Faucet, and Clamp 
records (rows) to select them, and then click Select.

4 Click OK to close the database grid and return to the 
Quick Printing dialog box.

5 Click Print.

Labels are printed for each of the selected records accord-
ing to the print quantities you selected.

Verify that the stock number increments by 1 with each 

label printed (i.e., 100001, 100002, etc.).

6 Click Close to return to the design window.
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